View Issue Details

IDProjectCategoryView StatusLast Update
0000710Other Unix PortBugpublic2020-03-11 02:33
ReporteremaxAssigned ToSteven Levine 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionduplicate 
Summary0000710: Stunnel 5.50 often crash (ticket ONLY for the crash issue)
Descriptionstunnel 5.50 on i386-pc-os2-emx built by Paul Smedley on Jan 13 2019
Compiled/running with OpenSSL 1.0.2n 7 Dec 2017

often crash, exceptq dump in attachment

OS: eCS 2.2b (running as VM in VBOX 6.1.2)

stunnel only used for pop3S (since weasel don't still have popS protocol), mta is on the same server (localhost)
Steps To Reproducedunno how to reproduce it, the feeiling is that it crash sometimes when mail (popS) clients go into timeout or such
TagsNo tags attached.

Relationships

duplicate of 0000705 assignedSteven Levine Stunnel 5.50 often crash 

Activities

emax

2020-03-10 21:24

reporter  

004A_03.TRP (40,559 bytes)

Steven Levine

2020-03-11 02:33

manager   ~0003413

Please do not create duplicate tickets for the same crash and please do not upload duplicate .trp files unless asked.

I should not have to tell you this. You should have spent the time to look at the .trp file and notice that the trap address is at exactly the same address as for ticket 0000705:

 00189587 >MOVDQU XMM1, DQWORD [EBP+0x10] (f30f6f4d 10)

Issue History

Date Modified Username Field Change
2020-03-10 21:24 emax New Issue
2020-03-10 21:24 emax File Added: 004A_03.TRP
2020-03-11 02:28 Steven Levine Relationship added duplicate of 0000705
2020-03-11 02:29 Steven Levine Assigned To => Steven Levine
2020-03-11 02:29 Steven Levine Status new => assigned
2020-03-11 02:33 Steven Levine Status assigned => closed
2020-03-11 02:33 Steven Levine Resolution open => duplicate
2020-03-11 02:33 Steven Levine Note Added: 0003413