View Issue Details

IDProjectCategoryView StatusLast Update
0000674ISC Bindpublic2018-04-24 19:15
ReporterggambaAssigned Topsmedley 
PrioritylowSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Summary0000674: Bind suddendly crashes
DescriptionBind running on a small home server: it can work fine for days, then suddendly crashes two or three times consecutively (as when it crashes it is automatically restarted), and then can run again without problems for days.

Not a big problem, anyway, as it does not happen too frequently and in a few seconds the service is restarted.
Additional InformationMessage from the console:

Killed by SIGABRT
pid=0xacd4 ppid=0x4551 tid=0x0007 slot=0x00cc pri=0x0200 mc=0x0001 ps=0x0010
C:\USR\SBIN\NAMED.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.


Message in syslogd:
Mar 22 19:05:15 GOLEM named.exe[44235]: starting BIND 9.10.4-P3 <id:7e49f11> -c c\:\\etc\\named\\named.conf
Mar 22 19:05:15 GOLEM named.exe[44235]: running on OS/2 i386 1 2.45
Mar 22 19:05:15 GOLEM named.exe[44235]: built with '--prefix=/bind9' '--disable-shared' '--enable-static' '--enable-largefile' '--enable-threads' '--disable-ipv6' '--disable-chroot' '--with-openssl=/extras' 'CC=gcc' 'LIBS=-llzma -llibcx0 -static-libgcc'
Mar 22 19:05:15 GOLEM named.exe[44235]: ----------------------------------------------------
Mar 22 19:05:15 GOLEM named.exe[44235]: BIND 9 is maintained by Internet Systems Consortium,
Mar 22 19:05:15 GOLEM named.exe[44235]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Mar 22 19:05:15 GOLEM named.exe[44235]: corporation. Support and training for BIND 9 are
Mar 22 19:05:15 GOLEM named.exe[44235]: available at https://www.isc.org/support
Mar 22 19:05:15 GOLEM named.exe[44235]: ----------------------------------------------------
Mar 22 19:05:15 GOLEM named.exe[44235]: found 4 CPUs, using 4 worker threads
Mar 22 19:05:15 GOLEM named.exe[44235]: using 3 UDP listeners per interface
Mar 22 19:05:15 GOLEM named.exe[44235]: using up to 2048 sockets
Mar 22 19:05:15 GOLEM named.exe[44235]: loading configuration from 'c:\etc\named\named.conf'
Mar 22 19:05:15 GOLEM named.exe[44235]: using default UDP/IPv4 port range: [1024, 65535]
Mar 22 19:05:15 GOLEM named.exe[44235]: using default UDP/IPv6 port range: [1024, 65535]
Mar 22 19:05:15 GOLEM named.exe[44235]: listening on IPv4 interface lan0, 192.168.0.1#53
Mar 22 19:05:15 GOLEM named.exe[44235]: listening on IPv4 interface lan1, 192.168.1.129#53
Mar 22 19:05:15 GOLEM named.exe[44235]: listening on IPv4 interface lan2, 192.168.2.1#53
Mar 22 19:05:15 GOLEM named.exe[44235]: listening on IPv4 interface lo, 127.0.0.1#53
Mar 22 19:05:15 GOLEM named.exe[44235]: generating session key for dynamic DNS
Mar 22 19:05:15 GOLEM named.exe[44235]: sizing zone task pool based on 8 zones
Mar 22 19:05:15 GOLEM named.exe[44235]: set up managed keys zone for view _default, file 'managed-keys.bind'
Mar 22 19:05:15 GOLEM named.exe[44235]: automatic empty zone: 10.IN-ADDR.ARPA
...
Mar 22 19:05:16 GOLEM named.exe[44235]: automatic empty zone: EMPTY.AS112.ARPA
Mar 22 19:05:16 GOLEM named.exe[44235]: command channel listening on 127.0.0.1#953
Mar 22 19:05:16 GOLEM named.exe[44235]: no source of entropy found
Mar 22 19:05:16 GOLEM named.exe[44235]: managed-keys-zone: loaded serial 0
Mar 22 19:05:16 GOLEM named.exe[44235]: zone 0.in-addr.arpa/IN: loaded serial 1
Mar 22 19:05:16 GOLEM named.exe[44235]: zone 127.in-addr.arpa/IN: loaded serial 1
Mar 22 19:05:16 GOLEM named.exe[44235]: zone 255.in-addr.arpa/IN: loaded serial 1
Mar 22 19:05:16 GOLEM named.exe[44235]: zone 2.168.192.in-addr.arpa/IN: loaded serial 201105270
Mar 22 19:05:16 GOLEM named.exe[44235]: zone localhost/IN: loaded serial 2
Mar 22 19:05:16 GOLEM named.exe[44235]: zone home/IN: loaded serial 201105270
Mar 22 19:05:16 GOLEM named.exe[44235]: db.golem:1: no TTL specified; using SOA MINTTL instead
Mar 22 19:05:16 GOLEM named.exe[44235]: zone golem.duckdns.org/IN: loaded serial 201105270
Mar 22 19:05:16 GOLEM named.exe[44235]: all zones loaded
Mar 22 19:05:16 GOLEM named.exe[44235]: running
Mar 22 19:05:17 GOLEM named.exe[44235]: socket.c:4299: fatal error:
Mar 22 19:05:17 GOLEM named.exe[44235]: select() failed: Bad address
Mar 22 19:05:17 GOLEM named.exe[44235]: exiting (due to fatal error in library)
TagsNo tags attached.

Activities

psmedley

2018-03-25 18:47

administrator   ~0003171

ah, the good old select() failure with bad address. I should be able to hack around that.

Probably time to update bind anyway. I'll try get to this over Easter.

ggamba

2018-03-26 17:25

reporter   ~0003172

Thank you Paul, too kind!

psmedley

2018-04-02 06:47

administrator   ~0003173

Building 9.11.3 now. I've added EFAULT (aka Bad Address) to the list of 'soft' errors for select which can be ignored.

psmedley

2018-04-02 07:53

administrator   ~0003174

Hi - please test http://smedley.id.au/tmp/bind-9.11.3-os2-20180402.zip

ggamba

2018-04-03 18:27

reporter   ~0003175

Thank you Paul,

installed and testing: I'll let you know in a few days!

ggamba

2018-04-24 18:32

reporter   ~0003180

Using http://smedley.id.au/tmp/bind-9.11.3-os2-20180402.zip, the reported problem never happened again, thanks!

psmedley

2018-04-24 19:15

administrator   ~0003181

Fixed in latest build

Issue History

Date Modified Username Field Change
2018-03-24 22:02 ggamba New Issue
2018-03-25 18:47 psmedley Note Added: 0003171
2018-03-26 17:25 ggamba Note Added: 0003172
2018-04-02 06:47 psmedley Note Added: 0003173
2018-04-02 07:53 psmedley Note Added: 0003174
2018-04-03 18:27 ggamba Note Added: 0003175
2018-04-22 19:02 psmedley Assigned To => psmedley
2018-04-22 19:02 psmedley Status new => feedback
2018-04-24 18:32 ggamba Note Added: 0003180
2018-04-24 18:32 ggamba Status feedback => assigned
2018-04-24 19:15 psmedley Status assigned => resolved
2018-04-24 19:15 psmedley Resolution open => fixed
2018-04-24 19:15 psmedley Note Added: 0003181