View Issue Details

IDProjectCategoryView StatusLast Update
0000556CUPS for OS/2 & eComStationBugpublic2021-04-09 19:30
ReporterLewisRAssigned Topsmedley 
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Summary0000556: When creating an ipp printer in the CUPS web GUI, the address field is pre-populated with "ipp.exe" vs "ip"
DescriptionExtremely trivial, but can throw the unknowing (unsuspecting) user. The reason for pre-populating the field on the Add Printer page is that we should already know, based upon the selection on the previous screen, what protocol to use, e.g., "hp," "lpd," "http," etc., after which the use merely appends the "://" or whichever syntax applies. However, in the case of selecting an ipp printer, we get the entire executable for the backend (ipp.exe) pre-populated in that field, leading one to wonder whether the then need to add a space, and then fill in "ipp://..." or use some other syntax.
Steps To Reproduce1. Open the CUPS web GUI in a browser.
2. Select the Administration tab.
3. Click the Add Printer button.
4. Select the radio button for "Internet Printing Protocol (ipp.exe)"
5. Click the Continue button.
Additional InformationAgain, Paul, this is extremely trivial, but as CUPS is generally confusing to the non-Linux user (as if native OS/2 printer objects aren't confusing to *everyone*!), this might lead to some false starts and further support requests, not to mention the whole "fit and polish" thing. ;-)
TagsNo tags attached.

Activities

LewisR

2012-12-22 07:23

developer   ~0002382

Should have mentioned: This is with CUPS 1.4.8.

psmedley

2012-12-22 07:36

administrator   ~0002383

hmmm this may well be non-trivial to fix - I suspect it's just looking for the contents of /cups/lib/cups/backend and saving the name of anything that will execute

Will see what I can do - I noticed this myself, just never got around to looking into it :)

psmedley

2012-12-22 07:37

administrator   ~0002384

ps, if you're not running the 1.4.8 build i posted to the ecups-dev mailing list in November, try this one: http://dl.dropbox.com/u/76425158/cups-1.4.8-os2-20121221.zip

LewisR

2012-12-22 08:37

developer   ~0002386

Thanks. I think I inadvertently rolled back a rev somewhere along the line. I'll apply this latest one. Having some issues getting ipp working (seems to be fine under openSUSE 12.2, CUPS 1.5.3). I'll open a separate ticket for that once I figure out what's going on (socket printing works fine to the same physical printer, so it appears to be something with the ipp backend).

psmedley

2013-04-17 18:42

administrator   ~0002424

see my post today to the ecups mailing list regarding ipp backend issues

psmedley

2021-04-09 19:30

administrator   ~0003628

bww now maintains CUPS

Issue History

Date Modified Username Field Change
2012-12-22 03:53 LewisR New Issue
2012-12-22 07:23 LewisR Note Added: 0002382
2012-12-22 07:36 psmedley Note Added: 0002383
2012-12-22 07:37 psmedley Note Added: 0002384
2012-12-22 08:37 LewisR Note Added: 0002386
2013-04-17 18:42 psmedley Note Added: 0002424
2021-04-09 19:30 psmedley Assigned To => psmedley
2021-04-09 19:30 psmedley Status new => closed
2021-04-09 19:30 psmedley Resolution open => fixed
2021-04-09 19:30 psmedley Note Added: 0003628