View Issue Details

IDProjectCategoryView StatusLast Update
0000506RsyncBugpublic2017-11-30 06:11
ReporterLewisRAssigned ToSteven Levine 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000506: unilistxattr DosQueryPathInfo FIL_QUERYEASIZE error 32 lib/sysxattrs.c(295) and llistxattr permission denied (13)
DescriptionUpgraded to rsync-3.0.8-20111230-shl.zip:

rsync version 3.0.8 protocol version 30
Built by Steven H. Levine Dec 30 2011 21:17:05
Built with GCC 4.5.2
Capabilities:
    64-bit files, 64-bit inums, 32-bit timestamps, 64-bit long ints,
    socketpairs, hardlinks, symlinks, no IPv6, batchfiles, inplace,
    append, no ACLs, xattrs, iconv, symtimes

Running:

c:\opt\rsync\bin\rsync.exe -r --xattrs --times --stats --human-readable --log-file=c:/var/log/rsync_cgp.log --exclude-from=c:/MPTN/ETC/rsync-cgp-exclude.lst j:/Communigate j:/CGP_Backup > nul 2>&1

throws above error at beginning of run:

2011/12/31 15:00:02 [2999] building file list
2011/12/31 15:00:06 [2999] [sender] unilistxattr DosQueryPathInfo(Communigate/Accounts/drrachel.macnt/INBOX.mbox, FIL_QUERYEASIZE) failed with error 32 lib/sysxattrs.c(295)
2011/12/31 15:00:06 [2999] rsync: get_xattr_names: llistxattr(""j://Communigate/Accounts/drrachel.macnt/INBOX.mbox"",1024) failed: Permission denied (13)
Steps To ReproduceRun rsync pass with --xattrs.
Additional Information4OS2 3.0.8 dir (source directory) says:

 Volume in drive J is DATA Serial number is 657E:D5BA
 Directory of J:\CommuniGate\Accounts\drrachel.macnt\*

12-30-11 22:10 <DIR> 0 .
 9-21-10 20:59 <DIR> 1,420 ..
12-30-11 23:31 1,416 0 account.info
 1-24-09 12:20 338 0 account.settings
12-30-11 23:31 21,438 0 INBOX.bdx
12-30-11 23:31 14,407,210 0 INBOX.mbox
12-30-11 22:10 9,582,292 0 Trash.mbox
      24,012,694 bytes (22MB) in 5 files and 2 dirs

This same error appeared on an INBOX.mbox which was 0 length. I believe the error is because the file is locked by Communigate Pro. This would explain the "Permission denied (13)" report.

I'm also seeing this on a non-mailbox file:

2011/12/31 15:32:12 [2999] [sender] unilistxattr DosQueryPathInfo(Communigate/Directory/Main.updates, FIL_QUERYEASIZE) failed with error 32 lib/sysxattrs.c(295)
2011/12/31 15:32:12 [2999] rsync: get_xattr_names: llistxattr(""j://Communigate/Directory/Main.updates"",1024) failed: Permission denied (13)
TagsNo tags attached.

Activities

Steven Levine

2012-01-01 08:40

manager   ~0002121

The permission denied is a unavoidable side-effect caused by how Communigate opens the file. You do have options that can workaround this issue without too much fuss. You can run rsync in two passes. The first pass backs up xattrs and excludes the problem files. The second pass selects only the problem files and omits the xattr option. An exclude filter like

  -f-_*.mbox

should be sufficient. An include filter set like
 -f+_**/
 -f+_*.mbox
 -f-_*

should be close to what you need for the mbox only rsync.

LewisR

2012-01-01 13:47

developer   ~0002123

Hmmm... So, while I have no trouble backing up these files with --no-xattrs (just tested on /Communigate/Directory/Main.updates), CGP's lock denies access when trying to glean the extended attributes from the file, and I know that's not an rsync issue, it's OS-specific.

I hadn't thought about what would be required to access the EAs. Thanks for the reminder.

Looking at the docs, there doesn't seem to be a more elegant way of doing this than your suggestion of two passes (e.g, a way to exclude EAs on specific files/patterns), unfortunately. However, I should be able to run these passes almost in parallel, as they're backing up different things.

Thanks, Steve. I'll give this a shot and will report back.

Steven Levine

2017-11-30 06:11

manager   ~0003154


This issue should be resolved by:

http://www.warpcave.com//betas/rsync-3.0.9.1-20171111-shl.zip

Issue History

Date Modified Username Field Change
2012-01-01 07:17 LewisR New Issue
2012-01-01 08:17 Steven Levine Assigned To => Steven Levine
2012-01-01 08:17 Steven Levine Status new => assigned
2012-01-01 08:40 Steven Levine Note Added: 0002121
2012-01-01 08:40 Steven Levine Status assigned => feedback
2012-01-01 13:47 LewisR Note Added: 0002123
2012-01-01 13:47 LewisR Status feedback => assigned
2017-11-30 06:11 Steven Levine Status assigned => resolved
2017-11-30 06:11 Steven Levine Resolution open => fixed
2017-11-30 06:11 Steven Levine Note Added: 0003154