View Issue Details

IDProjectCategoryView StatusLast Update
0000781Samba ServerBugpublic2024-01-22 17:33
Reporterpsmedley Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0000781: Log rotation issues
DescriptionFrom Dave on os2world:
One thing I have noticed - I have 'max log size = 2048' in the server smb.conf, but it seems to be ignored because I get logs over 10MB all the time, especially with log level = 8. Maybe a bug?
TagsNo tags attached.

Activities

psmedley

2024-01-20 10:36

administrator   ~0004670

@Dave - did this work correctly with Samba 3.x?

psmedley

2024-01-21 10:55

administrator   ~0004672

Looks like https://github.com/psmedley/samba-os2/blob/samba-os2-4.19.x/lib/util/debug.c#L1435 is supposed to handle the close/rename/reopen

psmedley

2024-01-21 10:59

administrator   ~0004673

Also, see https://trac.netlabs.org/samba/ticket/36

psmedley

2024-01-21 17:33

administrator   ~0004675

Partially fixed in https://github.com/psmedley/samba-os2/commit/a17dd06b5d4606496c0a44f8155008c2416d9366 build to follow. We better match the Samba 3.x code now.

psmedley

2024-01-21 17:34

administrator   ~0004676

https://smedley.id.au/tmp/smbd-4.19.4-20240121b.zip includes the below patch

David McKenna

2024-01-22 01:33

reporter   ~0004680

Don't remember about whether it worked with SAMBA 3 - and only noticed now it didn't as a result of testing with log level=8. I'll give your new build a try and let you know....

David McKenna

2024-01-22 05:48

reporter   ~0004681

Paul - it seems to be working. No log has gone over 2MB for several hours using log level = 8. Thanks!

Issue History

Date Modified Username Field Change
2024-01-20 07:28 psmedley New Issue
2024-01-20 07:31 psmedley Category 10 => Bug
2024-01-20 10:36 psmedley Note Added: 0004670
2024-01-21 10:55 psmedley Note Added: 0004672
2024-01-21 10:59 psmedley Note Added: 0004673
2024-01-21 17:33 psmedley Note Added: 0004675
2024-01-21 17:34 psmedley Assigned To => psmedley
2024-01-21 17:34 psmedley Status new => feedback
2024-01-21 17:34 psmedley Note Added: 0004676
2024-01-22 01:33 David McKenna Note Added: 0004680
2024-01-22 05:48 David McKenna Note Added: 0004681
2024-01-22 17:33 psmedley Status feedback => resolved
2024-01-22 17:33 psmedley Resolution open => fixed