View Issue Details

IDProjectCategoryView StatusLast Update
0000780Samba ServerBugpublic2024-02-04 07:21
Reporterpsmedley Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0000780: Investigate log.smbd errors
DescriptionI'm not seeing that error on either the client (4.19) or server (neither 4.11 nor 4.19). Using log level = 8 on both. All I see on the client side (both 4.11 and 4.19 server) is many dozens of:

1) [2024/01/19 11:32:59.648000, 3] ../../source3/libsmb/clierror.c:91(cli_status_to_errno)
  cli_status_to_errno: 0xc0000034 -> 2

 On the server side, the logged errors I see are:

2) [2024/01/19 10:01:17.493000, 2] ../../source3/nmbd/nmbd_winsserver.c:634(initialise_wins)
  initialise_wins: Can't open wins database file wins.dat. Error was No such file or directory**

3) [2024/01/19 10:01:40.006000, 5] ../../source3/nmbd/nmbd_namequery.c:77(query_name_response)
  query_name_response: On subnet UNICAST_SUBNET - negative response from IP 192.168.21.2 for name IBMPEERS<1b>. Error code was 3.**

4) [2024/01/19 10:19:00.702000, 0] ../../lib/util/pidfile.c:240(pidfile_unlink)
  Failed to delete pidfile C:\MPTN\ETC/samba/pid/nmbd.pid. Error was No such file or directory.**

5) [2024/01/19 10:18:30.430000, 3] ../../source3/smbd/smb2_server.c:4033(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_NO_MEMORY] || at ../../source3/smbd/smb2_create.c:360

6) [2024/01/19 10:18:30.622000, 5] ../../source3/smbd/dosmode.c:418(fget_ea_dos_attribute)
  fget_ea_dos_attribute: Cannot get attribute from EA on file .: Error = Attribute not found

7) [2024/01/19 10:18:32.229000, 3] ../../source3/smbd/smb2_server.c:4033(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_OBJECT_PATH_NOT_FOUND] || at ../../source3/smbd/smb2_create.c:360


 There were many multiples of each of the above - only one shown.

** Indicate errors seen with both the 4.11 and 4.19 server. The last three are only seen with the 4.19 server.

PS Edit 21JAN: added numerical references to each of these log entries
TagsNo tags attached.

Activities

psmedley

2024-01-21 09:02

administrator   ~0004671

1) I'll have to check my client logs and see if I see similar
2) I'll need to checkout paths- again - are you running nmbd?
3) is just noise. It's trying (I think) to resolve IBMPEERS to an IP, which fails.
4) Are you running nmbd.exe at the time this occurs? I don't think this is anything to worry about.
5) I'm guessing this is when the client is starting to fail? need more context to understand more about this one.
6) this is just noise - the server checks for an EA called user.DOSATTRIB where linux stores dos attributes
7) Need more context for this one too

David McKenna

2024-01-21 12:21

reporter   ~0004674

I am running nmbb, smbd, and winbindd (started by the Netlabs SAMBA CMD files which I have been using). I agree '5' is probably when the 'out of memory' raises it's head. I think '7' is when I try to read the share after the 'out of memory' has occurred, but I have a WPS display of files from before that and try to use one of the displayed files.

 Any idea what 'out of memory' is referring to? Is it the command prompt, the IFS, the samba plugin or what?

psmedley

2024-01-21 17:42

administrator   ~0004677

re: Item 1 - are those always surrounded by something like:
[2024/01/13 07:59:52.680000, 5] ../../libcli/smb/smb2_signing.c:574(smb2_signing_sign_pdu)
  signed SMB2 message (sign_algo_id=2)
[2024/01/13 07:59:52.686000, 3] ../../source3/libsmb/clierror.c:91(cli_status_to_errno)
  cli_status_to_errno: 0xc0000034 -> 2
[2024/01/13 07:59:52.688000, 5] ../../libcli/smb/smb2_signing.c:574(smb2_signing_sign_pdu)
  signed SMB2 message (sign_algo_id=2)

psmedley

2024-01-21 17:57

administrator   ~0004678

re: out of memory - it's actually some kind of Samba error code which is being mapped/converted to ENOMEM

I need to try and reproduce a log.smbd with -d 8 with the out of memory error to help try work out what's going wrong.

David McKenna

2024-01-22 01:18

reporter   ~0004679

re: item1, yes - exactly, I see the identical lines.

re: out of memory - so some kind of memory leak in the server? Seems odd that could happen, but Windows clients can still use the share when OS/2 says 'out of memory' - unless there is some kind of memory being mapped for each client?

David McKenna

2024-01-24 10:39

reporter   ~0004686

Another message I see repeated in log.smbd on the client that might be relevant:

[2024/01/23 09:38:37.511000, 3] ../../source3/smbd/smb2_server.c:1224(smbXsrv_server_multi_channel_enabled)
  'server multi channel support' enabled but not supported on OS/2 (1)
  Please report this on https://bugzilla.samba.org/show_bug.cgi?id=11897

David McKenna

2024-01-24 10:52

reporter   ~0004687

Another message I see repeated in log.smbd on the server that might be relevant:

[2024/01/23 09:38:37.511000, 3] ../../source3/smbd/smb2_server.c:1224(smbXsrv_server_multi_channel_enabled)
  'server multi channel support' enabled but not supported on OS/2 (1)
  Please report this on https://bugzilla.samba.org/show_bug.cgi?id=11897

David McKenna

2024-01-24 22:02

reporter   ~0004689

Please ignore message 4686...

psmedley

2024-01-27 19:01

administrator   ~0004690

The message in https://mantis.smedley.id.au/view.php?id=780#c4687 should be fixed in https://github.com/psmedley/samba-os2/commit/6aff9541d7a8aeacb21aef1251e97c34089cb9bf

David McKenna

2024-01-28 22:56

reporter   ~0004691

Since the recent ndpsmb-20240127 plugin, I have not seen errors 0000003, 5, 6, and 7 in server logs. Will there be a new smbd build with the fix mentioned above?

psmedley

2024-01-29 18:14

administrator   ~0004692

Just for you - https://smedley.id.au/tmp/smbd-4.19.4-20240129.zip

David McKenna

2024-01-29 21:51

reporter   ~0004693

Thanks! - this one is noticeably snappier displaying large directories on the client. I'd say it is now better than ver 4.11 was...

David McKenna

2024-01-31 22:04

reporter   ~0004696

With the ndpsmb-20240131 client version, I no longer see the errors listed with #1.

psmedley

2024-02-01 18:02

administrator   ~0004697

OK... so the remaining repeat errors are:
2) [2024/01/19 10:01:17.493000, 2] ../../source3/nmbd/nmbd_winsserver.c:634(initialise_wins)
  initialise_wins: Can't open wins database file wins.dat. Error was No such file or directory**

4) [2024/01/19 10:19:00.702000, 0] ../../lib/util/pidfile.c:240(pidfile_unlink)
  Failed to delete pidfile C:\MPTN\ETC/samba/pid/nmbd.pid. Error was No such file or directory.**

I don't typically bother running nmbd in my testing - so will do some investigation.

David McKenna

2024-02-01 21:39

reporter   ~0004698

0000004 is not really a problem, because there truly is no nmbd.pid - it was already deleted at the time of the message apparently.

David McKenna

2024-02-04 00:05

reporter   ~0004700

I think 0000002 may be working as designed. I noticed that when you start the server wins.dat gets deleted, and then recreated about 1-2 minutes later (searching the network for other servers?). So the server checks for the presence of wins.dat to see if it has been recreated yet. Go ahead and close this ticket - thanks!

psmedley

2024-02-04 07:21

administrator   ~0004701

Fixed in latest server

Issue History

Date Modified Username Field Change
2024-01-20 07:27 psmedley New Issue
2024-01-20 07:31 psmedley Category 10 => Bug
2024-01-21 08:58 psmedley Description Updated
2024-01-21 09:02 psmedley Note Added: 0004671
2024-01-21 12:21 David McKenna Note Added: 0004674
2024-01-21 17:42 psmedley Note Added: 0004677
2024-01-21 17:57 psmedley Note Added: 0004678
2024-01-22 01:18 David McKenna Note Added: 0004679
2024-01-24 10:39 David McKenna Note Added: 0004686
2024-01-24 10:52 David McKenna Note Added: 0004687
2024-01-24 22:02 David McKenna Note Added: 0004689
2024-01-27 19:01 psmedley Note Added: 0004690
2024-01-28 22:56 David McKenna Note Added: 0004691
2024-01-29 18:14 psmedley Note Added: 0004692
2024-01-29 21:51 David McKenna Note Added: 0004693
2024-01-31 22:04 David McKenna Note Added: 0004696
2024-02-01 18:02 psmedley Note Added: 0004697
2024-02-01 21:39 David McKenna Note Added: 0004698
2024-02-04 00:05 David McKenna Note Added: 0004700
2024-02-04 07:21 psmedley Assigned To => psmedley
2024-02-04 07:21 psmedley Status new => resolved
2024-02-04 07:21 psmedley Resolution open => fixed
2024-02-04 07:21 psmedley Note Added: 0004701