View Issue Details

IDProjectCategoryView StatusLast Update
0000779Samba Serverpublic2024-01-14 08:11
Reporterpsmedley Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0000779: Server leaves leftover files in C:\MPTN\ETC\samba\lock\msg.lock\
DescriptionAs above, Dave Mckenna posted on os2world:
"I've tried everything I could think of, but nothing helps. I even uninstalled SAMBA from the server, deleted all files in C:\MPTN\ETC\samba (there were 55000 files in\lock\msg.lock !) then reinstalled the Netlabs package, and upgraded to your latest SAMBA but still have the slowness issue at the client. Went back to 4.11 on the server and everything works well, even the 4.18 smbclient on the client machine works without -t 60 then.

BTW, deleting those 55000 files makes the server start MUCH faster. Wonder if there is a way to clean those up before the server is shut down..."
TagsNo tags attached.

Activities

psmedley

2024-01-09 18:51

administrator   ~0004654

Last edited: 2024-01-12 17:48

There is a good chance this is caused by the OS/2 specific changes in https://github.com/psmedley/samba-os2/blob/samba-os2-4.19.x/lib/messaging/messages_dgm.c

psmedley

2024-01-12 18:53

administrator   ~0004655

https://smedley.id.au/tmp/smbd-4.19.4-20240112.zip seems to improve the situation. I now only get left two 2x empty lock files, relating (I think) to the fact that smbd.exe gets a couple of forks but samba somehow doesn't keep track of the PID of the forked processes, so tries to remove the same lock file 3x times.

psmedley

2024-01-13 06:45

administrator   ~0004656

https://smedley.id.au/tmp/smbd-4.19.4-20240113.zip should correct this. It includes changes to clean up any errant lock files during smbd exit.

Issue History

Date Modified Username Field Change
2024-01-08 19:46 psmedley New Issue
2024-01-09 18:51 psmedley Note Added: 0004654
2024-01-12 17:48 psmedley Note Edited: 0004654
2024-01-12 18:53 psmedley Note Added: 0004655
2024-01-13 06:45 psmedley Note Added: 0004656
2024-01-13 14:24 psmedley Assigned To => psmedley
2024-01-13 14:24 psmedley Status new => feedback
2024-01-14 08:11 psmedley Status feedback => resolved
2024-01-14 08:11 psmedley Resolution open => fixed