View Issue Details

IDProjectCategoryView StatusLast Update
0000778PHP for OS/2, ArcaOS & eComStation (PHP versions v8.x v7.x v5.x)Feature Requestpublic2024-02-03 13:49
ReporterDavid McKenna Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel i5-9600OSArcaOSOS Version5.1.0
Product Version8.1.x 
Summary0000778: Can't run any browser when Apache with php8.1 is running
Description Tried to use Dooble to troubleshoot Wordpress on my computer running Apache and php 8.1.17. Dooble would not start giving a POPUPLOG:

12-25-2023 13:44:30 SYS2070 PID 0070 TID 0001 Slot 009d
C:\USR\BIN\DOOBLE.EXE
FREETYP6->BZ2._BZ2_bzDecompressEnd
127

 Stopping Apache, Dooble worked. Turns out there is a php module bz2.dll that conflicts with a different bz2.dll on my system. Would it be possible in future versions of php to rename that module - maybe php_bz2.dll?
Steps To Reproduce Run Apache with php 8.1.17. Try to start Dooble.
TagsNo tags attached.

Activities

psmedley

2023-12-29 10:28

administrator   ~0004649

Not sure I'd recommend running dooble on the same machine as one running apache2/php given both php and qtwebengine are known for being ram guzzlers.

I took a very quick look at this - the obvious change was to modify :
https://github.com/psmedley/php-os2/blob/main/main/build-defs.h.in#L41 to set PHP_SHLIB_EXT_PREFIX to "php-" but this didn't change anything. Potentially other changes also required.

Will investigate as time permits - but also concerned that this change will impact the naming of the various pdo plugins - and we'll run out of unique names without more changes....

David McKenna

2024-01-05 07:54

reporter   ~0004651

It's not a big deal - I was able to manually rename the DLL and change the entry in php.ini. Now I can run Dooble at the same time with memory to spare! Just thought it would be good if you could rename just the one bz2.dll, since it is the only one I can see that conflicts...

psmedley

2024-02-03 13:49

administrator   ~0004699

Should be fixed in https://github.com/psmedley/php-os2/commit/93ec260ead2842a035b8f4b823ba23c86e75f392

Issue History

Date Modified Username Field Change
2023-12-27 22:35 David McKenna New Issue
2023-12-29 10:28 psmedley Note Added: 0004649
2024-01-05 07:54 David McKenna Note Added: 0004651
2024-02-03 13:49 psmedley Assigned To => psmedley
2024-02-03 13:49 psmedley Status new => resolved
2024-02-03 13:49 psmedley Resolution open => fixed
2024-02-03 13:49 psmedley Note Added: 0004699