View Issue Details

IDProjectCategoryView StatusLast Update
0000696Subversion for OS/2 & eCSBugpublic2020-08-31 05:55
ReporterThomasikus Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformThinkpad T43OSeComStationOS Version2.1
Product Version1.7.x 
Fixed in Version1.14.x 
Summary0000696: Files containing Swedish characters cannot be added
DescriptionA file whose name contains one or more of the Swedish characters åäö cannot be added.
Using local svnserve (same machine) with svn: protocol (svn://localhost).
Steps To ReproduceSet up a local repository (using svnadmin) and start svnserve to work with this repository on svn://localhost.
I then try to add a file, thus:
[d:\prevas\testsvnmapp]svn add "radiostationer förklaring.sdw"
svn: warning: W155010: 'D:/Prevas/testsvnmapp/radiostationer förklaring.sdw' not found
svn: E200009: Could not add all targets because some targets don't exist
svn: E200009: Illegal target for the requested operation
Additional InformationI do realize that this behaviour could be a compromise to avoid other bugs, such as the previously reported problems with Unicode characters in filenames.
If you need any further information, I will gladly provide it.
TagsNo tags attached.

Activities

psmedley

2020-08-22 08:01

administrator   ~0003483

Pretty sure this is fixed in http://smedley.id.au/tmp/subversion-1.14.0-os2-20200731.zip

Thomasikus

2020-08-31 02:19

reporter   ~0003522

I am now running 1.14.0 (20200731) and can confirm that the issue is indeed fixed. I have tried adding several files with Swedish characters in the file names and it works. Thank you!

Issue History

Date Modified Username Field Change
2019-09-02 06:03 Thomasikus New Issue
2020-08-22 08:01 psmedley Assigned To => psmedley
2020-08-22 08:01 psmedley Status new => feedback
2020-08-22 08:01 psmedley Note Added: 0003483
2020-08-24 12:30 psmedley Product Version => 1.7.x
2020-08-31 02:19 Thomasikus Note Added: 0003522
2020-08-31 02:19 Thomasikus Status feedback => assigned
2020-08-31 05:55 psmedley Status assigned => closed
2020-08-31 05:55 psmedley Resolution open => fixed
2020-08-31 05:55 psmedley Fixed in Version => 1.14.x