View Issue Details

IDProjectCategoryView StatusLast Update
0000677Other Unix PortBugpublic2018-05-13 18:50
Reporterggamba Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Summary0000677: Can't initialize postgresql database with ver. 9.66
DescriptionThe script that worked fine with 9.06 for dbase initialization, doesn't work anymore with 9.66, with the following error:

...
running bootstrap script ... LOG: 00000: invalid binary "E:/pgsql/bin/"E:/pgsql/bin/postgres.exe"
LOCATION: find_my_exec, exec.c:146
LOG: 00000: invalid binary "E:/pgsql/bin/"E:/pgsql/bin/postgres.exe"
LOCATION: find_my_exec, exec.c:146
FATAL: XX000: "E:/pgsql/bin/postgres.exe": could not locate my own executable path
LOCATION: InitStandaloneProcess, miscinit.c:236
child process exited with exit code 1
...

full transcripts of running scripts for both ver. 9.06 and 9.66 are attached. Maybe is just something wrong in my script?

TagsNo tags attached.

Activities

ggamba

2018-05-09 23:09

reporter  

906.log (1,619 bytes)   
[E:\pgsql]@prompt epm: $p $g 

epm: E:\pgsql >set beginlibpath=e:\pgsql\bin;e:\pgsql\lib; 

epm: E:\pgsql >SET USE_HOSTS_FIRSTS=Y 

epm: E:\pgsql >set PGDATA=e:/data

epm: E:\pgsql >set LANG=it_IT 

epm: E:\pgsql >cd bin

epm: E:\pgsql\bin >initdb
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale it_IT .ISO8859-1.
The default database encoding has accordingly been set to LATIN1.
The default text search configuration will be set to "italian".

fixing permissions on existing directory e:/data ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 32MB
creating configuration files ... ok
creating template1 database in e:/data/base/1 ... ok
initializing pg_authid ... ok
initializing dependencies ... ok
creating system views ... ok
loading system objects' descriptions ... ok
creating conversions ... ok
creating dictionaries ... ok
setting privileges on built-in objects ... ok
creating information schema ... ok
loading PL/pgSQL server-side language ... ok
vacuuming database template1 ... ok
copying template1 to template0 ... ok
copying template1 to postgres ... ok

WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the -A option the
next time you run initdb.

Success. You can now start the database server using:

    postgres -D e:/data
or
    pg_ctl -D e:/data -l logfile start


epm: E:\pgsql\bin > 
906.log (1,619 bytes)   
966.log (1,706 bytes)   
[E:\pgsql]@prompt epm: $p $g 

epm: E:\pgsql >set beginlibpath=e:\pgsql\bin;e:\pgsql\lib; 

epm: E:\pgsql >SET USE_HOSTS_FIRSTS=Y 

epm: E:\pgsql >set PGDATA=e:/data

epm: E:\pgsql >set LANG=it_IT 

epm: E:\pgsql >cd bin

epm: E:\pgsql\bin >initdb -E UTF8
LOG:  00000: invalid binary "E:/pgsql/bin/"E:/pgsql/bin/postgres.exe"
LOCATION:  find_my_exec, exec.c:146
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale "it_IT .IBM-850".
could not determine encoding for locale "it_IT .IBM-850": codeset is "IBM-850"
could not determine encoding for locale "it_IT .IBM-850": codeset is "IBM-850"
The default text search configuration will be set to "italian".

Data page checksums are disabled.

fixing permissions on existing directory e:/data ... ok
creating subdirectories ... ok
selecting default max_connections ... 10
selecting default shared_buffers ... 400kB
selecting dynamic shared memory implementation ... sysv
creating configuration files ... ok
running bootstrap script ... LOG:  00000: invalid binary "E:/pgsql/bin/"E:/pgsql/bin/postgres.exe"
LOCATION:  find_my_exec, exec.c:146
LOG:  00000: invalid binary "E:/pgsql/bin/"E:/pgsql/bin/postgres.exe"
LOCATION:  find_my_exec, exec.c:146
FATAL:  XX000: "E:/pgsql/bin/postgres.exe": could not locate my own executable path
LOCATION:  InitStandaloneProcess, miscinit.c:236
child process exited with exit code 1
initdb: removing contents of data directory "e:/data"

epm: E:\pgsql\bin > 





The script that worked fine with 9.06 for dbase initialization, doesn't work anymore with 
966.log (1,706 bytes)   

ggamba

2018-05-09 23:14

reporter   ~0003186

It seems something is changed in the initdb procedure? While 9.06 passed happily the "creating template1 database in e:/data/base/1" line, the corresponding "running bootstrap script" line in 9.66 fails.

psmedley

2018-05-13 09:50

administrator   ~0003187

what build of 9.6.6? http://smedley.id.au/tmp/postgresql-9.6.6-os2-20180101.zip

ggamba

2018-05-13 18:50

reporter   ~0003188

www.dropbox.com/s/8hkit4gq4b8kedt/postgresql-9.6.6-os2-20180103.zip

Issue History

Date Modified Username Field Change
2018-05-09 23:09 ggamba New Issue
2018-05-09 23:09 ggamba File Added: 906.log
2018-05-09 23:09 ggamba File Added: 966.log
2018-05-09 23:14 ggamba Note Added: 0003186
2018-05-13 09:50 psmedley Note Added: 0003187
2018-05-13 18:50 ggamba Note Added: 0003188