View Issue Details

IDProjectCategoryView StatusLast Update
0000657RsyncBugpublic2017-11-30 06:09
ReporterDougBAssigned ToSteven Levine 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformOS/2OSOS/2OS VersioneCS 2.1
Product Version3.0.6 
Target VersionFixed in Version 
Summary0000657: RSync 3.09 (SHL) and Zip 3.0 (July 5th 2008), crash when they encounter a file that has a blank EA, with no data.
Description I have encountered a few cases where a file has a blank EA, with no data, in the middle of the EA list (as shown by FM/2 edit Extended Attributes). RSync, and ZIP, both crash when they encounter such a file. See Crash.txt in RSYNCCRASH.zip for details, and a sample file.

I have not, yet, determined what is actually creating the EAs that cause the problem (see Crash,txt, which describes how I created the file), but neither program should crash when they encounter the problem. It appears that most programs simply drop all of the EAs when they encounter it.
Steps To ReproduceSee Crash.txt in RSYNCCRASH.zip for details.
Additional InformationProduct Version was reported as 3.0.6 because that is the closest option to the real version which is 3.0.9 (SHL).

SHL suggested that I should report this here.
TagsNo tags attached.

Activities

DougB

2015-10-29 04:39

reporter  

RSYNCCRASH.zip (25,057 bytes)

Steven Levine

2015-11-04 05:31

manager   ~0003067

This turns out to be a kernel defect in DosEnumAttribute. Given the broken EAs in the testcase, FEA2 list is not returned as documented, if more than 1 EA is returned. The result is a trap when the code attempts to dereference the oNextEntry pointer. I will update rsync to report this as an error which would have been the case if the kernel had detected the malformed EA data.

Steven Levine

2015-11-04 05:32

manager   ~0003068

See also: http://trac.netlabs.org/ports/ticket/73

Steven Levine

2017-11-13 02:32

manager   ~0003148

Try

  http://www.warpcave.com//betas/rsync-3.0.9.1-20171111-shl.zip

It should avoid this exception.

DougB

2017-11-14 06:19

reporter   ~0003150

Okay, I have it. I will try to properly test it in the next few days, and report back. Thanks...

DougB

2017-11-17 02:54

reporter   ~0003151

I haven't been able to create a new defective file, but the fixed version does handle the supplied sample okay.

It seems to me that this should actually be a system wide fix, not just for RSync, but I will leave that up to you. ZIP is still broken, and I need to report that.

Steven Levine

2017-11-30 06:09

manager   ~0003152

Appears to be resolved by

  http://www.warpcave.com//betas/rsync-3.0.9.1-20171111-shl.zip

Issue History

Date Modified Username Field Change
2015-10-29 04:39 DougB New Issue
2015-10-29 04:39 DougB File Added: RSYNCCRASH.zip
2015-11-04 05:31 Steven Levine Note Added: 0003067
2015-11-04 05:31 Steven Levine Assigned To => Steven Levine
2015-11-04 05:31 Steven Levine Status new => assigned
2015-11-04 05:32 Steven Levine Note Added: 0003068
2017-11-13 02:32 Steven Levine Status assigned => feedback
2017-11-13 02:32 Steven Levine Note Added: 0003148
2017-11-14 06:19 DougB Note Added: 0003150
2017-11-14 06:19 DougB Status feedback => assigned
2017-11-17 02:54 DougB Note Added: 0003151
2017-11-30 06:09 Steven Levine Status assigned => resolved
2017-11-30 06:09 Steven Levine Resolution open => fixed
2017-11-30 06:09 Steven Levine Note Added: 0003152