View Issue Details

IDProjectCategoryView StatusLast Update
0000641MySQL v5 for OS/2 & eComStationFeature Requestpublic2014-12-30 05:44
ReporterSteven Levine Assigned ToSteven Levine  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformOS2/eCSOSOS/2 or eComstationOS Version1.x 2.x or 4.5
Product Version5.1.72 
Fixed in Version5.1.72 
Summary0000641: apache server stops responding to simple requests from ab.exe
DescriptionA stress test run as

  ab -c1 -n4000 http://slamain/hello-db.php

never completes. apache stops responding after some number of requests - typically between 500 and 3500. The failure is not permanent. If one waits a bit and retrys, apache will responds to some number of new requests before it again stops responding. It appears that whatever resource is causing the failure mode is released after some period of time.

hello-db.php is a simple select query using the mysqli interface.

Similar tests

  ab -c1 -n10000 http://slamain/hello.php
  ab -c1 -n10000 http://slamain/

which eliminate mysql from the processing chain run to completion which implies that the issues is either in the mysqli php extension or the mysql daemon.
TagsNo tags attached.

Relationships

duplicate of 0000642 new Apache 2.x  apache stops responding to simple mysql requests from ab.exe 

Activities

Steven Levine

2014-12-30 04:53

manager  

hello-db.php (869 bytes)

Issue History

Date Modified Username Field Change
2014-12-30 04:53 Steven Levine New Issue
2014-12-30 04:53 Steven Levine File Added: hello-db.php
2014-12-30 05:44 Steven Levine Relationship added duplicate of 0000642
2014-12-30 05:44 Steven Levine Status new => closed
2014-12-30 05:44 Steven Levine Assigned To => Steven Levine
2014-12-30 05:44 Steven Levine Resolution open => duplicate
2014-12-30 05:44 Steven Levine Fixed in Version => 5.1.72