View Issue Details

IDProjectCategoryView StatusLast Update
0000594Other Unix PortBugpublic2014-08-08 18:44
Reporteros2darcioAssigned Topsmedley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 build, Phenom Xii CPU, MSIOSOS/2OS Version4.52 CP2 SMP
Summary0000594: GhostView with Ghostscript 9.10 fails to print all documents
DescriptionRecently upgraded to Ghostcript 9.10, I am now unable to print any documents. Getting the following error message:

=== START ===
GPL Ghostscript 9.10 (2013-08-30)
Copyright (C) 2013 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Unknown device: pswrite
Unrecoverable error: undefined in .uninstallpagedevice
Operand stack:
    defaultdevice
gsapi_exit returns 0
DosFreeModule returns 12
=== END ===

Researching this appaers to indicate that 'pswrite' is a depreceated output device which has been replaced by ps2write. I am not certain of what this means to the OS/2 port however.

Tried multiple different documents, none printed.

I am using a PostScript printer here, Brother HL-1650N (network enabled). Using os2prn device in GhostView. Also attempted to print to non-PostScript printer (same printer but configured as a HP LJ emulation), no luck, the print job showed the following message:

=== START ===
GPL Ghostscript 9.10 (2013-08-30)
Copyright (C) 2013 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
   **** Warning: An error occurred while reading an XREF table.
   **** The file has been damaged. This may have been caused
   **** by a problem while converting or transfering the file.
   **** Ghostscript will attempt to recover the data.
Page 1
=== END ===

Watching the printer queue I saw a 0 (zero) byte file spooling which never actually became larger then this.
Steps To ReproduceOpen a PDF file in GhostView and attempt to print.
TagsNo tags attached.

Activities

psmedley

2014-01-23 19:24

administrator   ~0002640

Sounds like gsview needs to be updated to use pswrite2. Which version of gsview?

psmedley

2014-01-23 19:26

administrator   ~0002641

You could also try Andy Willis's GS View 5.0 build from http://hobbes.nmsu.edu/download/pub/os2/util/printer/ghost/gsv50os2.zip

os2darcio

2014-01-24 13:20

reporter   ~0002642

Paul,

I tried that version 5.0 of GSView. Same result, tried multiple files:

=== START ===
GPL Ghostscript 9.10 (2013-08-30)
Copyright (C) 2013 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Unknown device: pswrite
Unrecoverable error: undefined in .uninstallpagedevice
Operand stack:
    defaultdevice
gsapi_exit returns 0
DosFreeModule returns 12
=== END ===

Now, here is something else I can narrow this down to. I still have the older GSView 4.97 and the new 5.00 installed. Switching both of them back to ghostscript 9.04 allows me to print without any problems.

Adding further, the window scrolling speed while using gs 9.10 is VERY slow. Watching the CPU meter actually shows a single CPU core at a time running with a nearly 100% load. In comparison the 9.04 version shows multiple cores all running in parallel. The result in speed is about tenfold.

So I'm curious whether the 9.10 drop is compiled with some options that changed the behaviour of the app?

psmedley

2014-01-26 08:40

administrator   ~0002646

from gsview code:
    else if (method == PRINT_PS) {
    device = "pswrite";
    resolution = "600"; /* a guess */
    }


Looks like gsview needs updating for newer ghostscript versions that remove pswrite

psmedley

2014-01-26 11:44

administrator   ~0002647

Try editing x:\gs\gsview2\printer.ini and changing the pswrite entry to pswrite2

os2darcio

2014-03-16 00:20

reporter   ~0002697

As previously reported (email though I think...so here is the matching update) changing the printer.ini entries has NO effect. During the print job attempt the following error message is generated:

=== START ===
GPL Ghostscript 9.10 (2013-08-30)
Copyright (C) 2013 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Unknown device: pswrite
Unrecoverable error: undefined in .uninstallpagedevice
Operand stack:
    defaultdevice
gsapi_exit returns 0
DosFreeModule returns 12
=== END ===

It looks like the code is still looking for 'pswrite' as the device. This error matches what is being displayed even with when the printer.ini file entries are set to 'pswrite' as opposed to 'pswrite2'.

Thanks!

psmedley

2014-08-08 18:42

administrator   ~0002806

Change the entry in c:\OS2\gvpm.ini from pswrite to ps2write

Issue History

Date Modified Username Field Change
2014-01-23 04:00 os2darcio New Issue
2014-01-23 19:24 psmedley Note Added: 0002640
2014-01-23 19:26 psmedley Note Added: 0002641
2014-01-24 13:20 os2darcio Note Added: 0002642
2014-01-26 08:40 psmedley Note Added: 0002646
2014-01-26 11:44 psmedley Note Added: 0002647
2014-02-09 10:22 psmedley Assigned To => psmedley
2014-02-09 10:22 psmedley Status new => feedback
2014-03-16 00:20 os2darcio Note Added: 0002697
2014-03-16 00:20 os2darcio Status feedback => assigned
2014-08-08 18:42 psmedley Note Added: 0002806
2014-08-08 18:44 psmedley Status assigned => resolved
2014-08-08 18:44 psmedley Resolution open => fixed