View Issue Details

IDProjectCategoryView StatusLast Update
0000578PHP 5.x for OS/2 & eComStationBugpublic2013-09-23 20:03
ReporterIgor VaskovAssigned Topsmedley 
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionwon't fix 
Platformx86OSOS/2OS VersionECS 2.0
Product Version 
Target VersionFixed in Version 
Summary0000578: PHP 5.3.17
DescriptionRandom error in the function iconv.
Replacing function ikonv a function written in php to avoid mistakes.
Perhaps the problem is that the used uconv.dll not ready for multiprocessing.
Fix uconv.dll for multiprocessing is present, but does not solve the problem.
In attache the trap.
TagsNo tags attached.

Relationships

related to 0000584 closedpsmedley php iconv not working (latest kit) 

Activities

Igor Vaskov

2013-07-24 23:55

reporter  

1CDD_03.TRP (50,562 bytes)

psmedley

2013-07-27 08:26

administrator   ~0002459

the trp file would be more useful if you had the map files present for ucv32, libc065, php5 and modphp5

Any reason you're using 5.3.17 and not a more recent php?

Igor Vaskov

2013-07-27 20:26

reporter   ~0002460

Sorry. I have no other maps files. Only those that are in the distribution. Where to get them?
I have uconv fix from this
http://mantis.smedley.id.au/file_download.php?file_id=283&type=bug
It is very stable fix for multiprocessing.

I use php 5.3.17 because it is the most stable version of the latest.
Version 5.3.20 unstable on my configuration.
I noticed that the php script for some reason, writes to the database two same lines instead of one (INSERT operation). It is big problem for my.
And undo 5.3.17 version.

psmedley

2013-09-23 20:03

administrator   ~0002525

Won't fix 5.3.17 - too old

Issue History

Date Modified Username Field Change
2013-07-24 23:55 Igor Vaskov New Issue
2013-07-24 23:55 Igor Vaskov File Added: 1CDD_03.TRP
2013-07-27 08:26 psmedley Note Added: 0002459
2013-07-27 20:26 Igor Vaskov Note Added: 0002460
2013-09-19 02:52 Steven Levine Relationship added related to 0000584
2013-09-23 20:03 psmedley Note Added: 0002525
2013-09-23 20:03 psmedley Status new => closed
2013-09-23 20:03 psmedley Assigned To => psmedley
2013-09-23 20:03 psmedley Resolution open => won't fix