View Issue Details

IDProjectCategoryView StatusLast Update
0000573PHP for OS/2, ArcaOS & eComStation (PHP versions v8.x v7.x v5.x)Feature Requestpublic2013-05-04 14:38
Reporterasavage Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Platformx86OSeCSOS Version2.1
Summary0000573: README.OS2 additions requested
DescriptionThe current README.OS2 could be enhanced with additional documentation, specifically the destination for various files contained in the ZIP.
Additional InformationSuggested draft follows. There is some ambiguity as to where php5.map and modphp5.map should go, and I've left "???" as placeholders in the text below.

========================================
This is a port of PHP v5.4.10 to OS/2.

New in this build is:
- Updated to PHP 5.4.10 source

Requires a copy of libc065.dll which can currently be downloaded from ftp://ftp.netlabs.org/pub/gcc/libc-0.6.5-csd5.zip

A guide to where to extract files:
\php-5.4.10-os2-20121223.zip
+--php5
        php.ini.sample
        php.exe
        modphp5.map
        php5.dll
        php5.map
   +--apache2
        modphp5.dll
   +--cgi
         php.exe
   +--modules
         xsl.dll
         pgsql.dll
         pdo_sqli.dll
         pdo_odbc.dll
         pdo_mysq.dll
         odbc.dll
         mysqli.dll
         mysql.dll
         mcrypt.dll
         mbstring.dll
         imap.dll
         iconv.dll
         gettext.dll
         gd.dll
         exif.dll
         curl.dll
         bz2.dll
         openssl.dll

* If this is a new installation, extract /php.ini.sample to %ETC% and rename to php.ini if you wish. Edit to suit. See notes on timezone setting below.
* Extract /php.dll to a dir on LIBPATH . If using with Apache, you can generally put it where httpd.dll resides (/Apache2, etc.)
* Extract /cgi/php.exe to your Apache cgi dir if you plan on running php as CGI, or elsewhere if you wish to run it commandline.
* To load the Apache2 module, copy Apache2/modphp5.dll to the Apache2 module directory, and add:
    LoadModule php5_module modules/modphp5.dll
  to httpd.conf. Some users have reported that modphp5 needs to be the LAST module loaded.
* Extract modphp5.map to ???
* Extract php5.map to ???
* Extract /modules/*.dll to somewhere that matches the line in php.ini
   extension_dir =

Patches for thread support and detection of php.ini in c:\mptn\etc have been included in the executable largely based on Brian Havard's patches for PHP 4.3.1

I have included support for some external modules - bz2, curl, dbase, gd, exif, filepro,, gd, gettext, mbstring, mysql, mysqli, openssl, pdo_mysql, pdo_sqlite, pgsql (postgresql) & sqlite are loadable as shared modules. Other modules including those from pecl, can most likely be built pretty easily - if there is something you need, please contact me.

PHP has problems detecting the timezone in OS/2 - to workaround this, and set the default in your php.ini you need to add date.timezone simular to what is shown below in context. You can get the timezones supported in the php.ini from : http://us2.php.net/manual/en/timezones.php

;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

[Date]
; Defines the default timezone used by the date functions
date.timezone = Australia/Adelaide

As always, any feedback to paul@smedley.id.au is appreciated - bug reports should be submitted via the bugtracker at http://mantis.smedley.id.au. It's really nice to hear of people using my ports!

If you like this software and want to support continued ports, please consider donating via PayPal via the link at http://os2ports.smedley.id.au, or via the Mensys online store at http://www.mensys.net/os2ports

Cheers,

Paul Smedley
Adelaide, Australia
23rd December, 2012
========================================
TagsNo tags attached.
Attached Files
readme.os2 (3,108 bytes)

Activities

Issue History

Date Modified Username Field Change
2013-05-04 14:38 asavage New Issue
2013-05-04 14:38 asavage File Added: readme.os2