View Issue Details

IDProjectCategoryView StatusLast Update
0000530MySQL v5 for OS/2 & eComStationBugpublic2022-05-14 16:13
ReporterLewisR Assigned Topsmedley  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0000530: MySQL 5.1.61 default config file fails with socket directive
Descriptionmy-medium.cnf contains the following socket references:

# The following options will be passed to all MySQL clients
[client]
socket = \socket\MySQL

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
socket = \socket\MySQL

When the server comes up, it complains about not being able to locate "ocket\MySQL". Likewise, when starting mysqladmin, a similar message is displayed.

Steps To Reproduce1. Copy my-medium.cnf to %ETC%\my.cnf (do not edit).
2. Start mysqld.exe.
3. Error displays (along with a warning about skip-locking becoming deprecated, and to use skip-external-locking).
4. Daemon shuts down.
Additional InformationThe first line in the daemon window is the old "TlsAllocThreadLocalMemory error: init already done!" error, which is apparently cosmetic.

The default cnf should be changed to update the skip-locking directive to skip-external-locking (I've used this syntax on NetWare since 5.0; I'm not sure why the default config files do not include it).

However, commenting the socket directives results in the server and the client(s) utilizing the default socket (\socket\MySQL) without complaint. It is only when explicitly stated in my.cnf that this is an issue.

The server in question is a fresh (last week) install of eCS 2.1 running the latest available GCC 4 core and libc064.dll (full libc063.dll, *not* the forwarder). The hardware is an HP Proliant ML370 G2 with 4GB RAM.
TagsNo tags attached.

Activities

psmedley

2012-03-25 12:41

administrator   ~0002227

can you try \\socket\\MySQL

LewisR

2012-03-25 14:36

developer   ~0002228

Confirmed, Paul. Escaping the backslashes does the trick. I didn't try it, but would it then be reasonable to expect that the second backslash is safe, i.e.:

\\socket\MySQL

?

I should have thought to try your suggestion before posting. ;-)

Thanks.

psmedley

2012-03-25 15:05

administrator   ~0002229

Hi Lewis,

Glad it helped. I would have thought \\socket\mysql wouldn't work either - but your error suggests it might...

LewisR

2012-03-25 15:47

developer   ~0002230

Indeed, Paul. I just tested again.

\\socket\MySQL

works just as well. ;-)

So, however, you want to close this ticket is fine by me. You could add this as a readme item or if your packaging system allows you to tweak the sample config files, either should do. It's just another one of those little "head scratchers" when first configuring, that's all.

Cheers/2

Issue History

Date Modified Username Field Change
2012-03-20 13:11 LewisR New Issue
2012-03-25 12:41 psmedley Note Added: 0002227
2012-03-25 14:36 LewisR Note Added: 0002228
2012-03-25 15:05 psmedley Note Added: 0002229
2012-03-25 15:47 LewisR Note Added: 0002230
2022-05-14 16:13 psmedley Assigned To => psmedley
2022-05-14 16:13 psmedley Status new => resolved
2022-05-14 16:13 psmedley Resolution open => no change required