View Issue Details

IDProjectCategoryView StatusLast Update
0000508Other Unix PortBugpublic2021-04-10 07:35
ReporterAlexTaylorAssigned Topsmedley 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformOS/2OSeComStationOS Version2.1
Summary0000508: tar (v1.26) cannot create archives
DescriptionAttempting to create a tarball with the syntax below fails with tar 1.26:

[C:\var]tar cvf test1.tar some-dir
tar: some-dir/: Cannot savedir: Operation not supported on socket
tar: Exiting with failure status due to previous errors

The above worked as expected with v1.20.
Additional InformationTrying the following syntax also fails, but with a different error message:

[C:\var]tar cvf test2.tar some-dir/*
tar: some-dir/*: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors

(This, too, worked with v1.20.)
TagsNo tags attached.

Activities

psmedley

2012-01-03 17:36

administrator   ~0002127

I'm thinking it's assuming the file is a remote drive due to the : in the full path (once the path is resolved).

psmedley

2012-01-03 18:45

administrator   ~0002128

yucky gnu lib code...

I have partially fixed this in http://smedley.info/tar-1.26-os2-20120103.zip to the point where it at least creates a tar but still gives a warning about stat failing due to bad file number

psmedley

2021-04-10 07:35

administrator   ~0003630

bww now maintains tar

Issue History

Date Modified Username Field Change
2012-01-03 12:08 AlexTaylor New Issue
2012-01-03 17:33 psmedley Assigned To => psmedley
2012-01-03 17:33 psmedley Status new => assigned
2012-01-03 17:36 psmedley Note Added: 0002127
2012-01-03 18:45 psmedley Note Added: 0002128
2021-04-10 07:35 psmedley Status assigned => closed
2021-04-10 07:35 psmedley Resolution open => won't fix
2021-04-10 07:35 psmedley Note Added: 0003630