View Issue Details

IDProjectCategoryView StatusLast Update
0000491GCC - GNU C CompilerBugpublic2015-01-20 05:36
ReporterdmikAssigned Topsmedley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000491: GCC 4.4.2 prepends an asterisk ('*') to the symbols with the _System attribute
DescriptionThe full description of the problem is here: [^] (comment 3).

Back then, I fixed this in emxomf.exe but the correct place to fix the problem is GCC.

I can't recall any test case for that ATM though. I will post one if I'm able to reproduce it.

This applies to GCC 4.4.2 in the first place and I guess to all later versions as well.
TagsNo tags attached.



2011-11-01 18:57

administrator   ~0002032

A testcase would be good - but I'm wondering if the latest GCC 4.4.6 (with the git.diff I sent you) still does this?

I will upload a new public build once I complete some more testing


2015-01-20 01:03

reporter   ~0003015

Paul, haven't you fixed this within By this change set ( If so, this one needs to be closed I think.


2015-01-20 05:36

administrator   ~0003016


Issue History

Date Modified Username Field Change
2011-10-04 18:25 dmik New Issue
2011-11-01 18:57 psmedley Note Added: 0002032
2015-01-20 01:03 dmik Note Added: 0003015
2015-01-20 05:36 psmedley Note Added: 0003016
2015-01-20 05:36 psmedley Status new => resolved
2015-01-20 05:36 psmedley Resolution open => fixed
2015-01-20 05:36 psmedley Assigned To => psmedley