View Issue Details

IDProjectCategoryView StatusLast Update
0000465Apache 2.x Bugpublic2021-06-07 23:06
Reportervrwp Assigned ToSteven Levine  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformos/2OSecomstation v2 
Product Versionv2.2.1 
Summary0000465: not able to run rexx cgi-bin scripts
DescriptionI have a website, which uses forms attributes, the submit button calls a rexxscript which uses the rxweb plugin.
After choosing the submit button the system keeps waiting for the script to complete.
Killing the window in which apache is running ( I have to hit 2 times ctrl-c) I get the following in the log file from apache
[Mon Feb 21 22:56:07 2011] [notice] Apache/2.2.17 (OS/2) PHP/5.3.4 configured -- resuming normal operations
[Mon Feb 21 23:32:40 2011] [error] [client 127.0.0.1] File does not exist: E:/internet/apache/Data/htdocs/favicon.ico
[Mon Feb 21 23:32:40 2011] [error] [client 127.0.0.1] File does not exist: E:/internet/apache/Data/htdocs/favicon.ico
[Mon Feb 21 23:33:51 2011] [error] [client 127.0.0.1] Premature end of script headers: kees.cmd, referer: http://127.0.0.1/kees.html
[Mon Feb 21 23:33:51 2011] [error] [client 127.0.0.1] 9 +++ hostinterne = getformdata(HTTP_USER_AGENT);\r, referer: http://127.0.0.1/kees.html
[Mon Feb 21 23:33:51 2011] [error] [client 127.0.0.1] REX0004: Error 4 running E:\\internet\\apache2\\cgi-bin\\kees.cmd, line 9: Program\r, referer: http://127.0.0.1/kees.html
[Mon Feb 21 23:33:51 2011] [error] [client 127.0.0.1] interrupted\r, referer: http://127.0.0.1/kees.html

The funny thing is that running that running the script directly (choosing http://127.0.0.1/cgi-bin/kees.cmd. Lets the script run. So I think the configuration of apache is good.
But don't have an idea what's going wrong with apache. (version 2.2.17)
Steps To Reproducetried website and script with the web2 browser, everything works flawlessly
TagsNo tags attached.

Activities

vrwp

2011-05-20 05:53

reporter   ~0001919

I think, I found a hint.
when I use <FORM METHOD="post" ACTION="http://localhost/cgi-bin/4dkl.cmd" target="ondscherm">
apache won't work, no page displayed from the rexx script.
using <FORM METHOD="get" ACTION="http://localhost/cgi-bin/ubos.cmd" target="ondscherm">
it works.
The only difference is using post or get method.
Post method should handle longer information than get, that's why I use sometimes the post method.
web2 works with both types and files.

vrwp

2011-05-20 22:28

reporter   ~0001920

Could this help?
some information about the same problem post (php) and apache
http://bugs.gentoo.org/show_bug.cgi?id=363443

Steven Levine

2021-06-07 23:06

manager   ~0003718

We cannot reproduce this with current httpd builds. If this is still an issue for you, please reopen the ticket with updated testcase data.

Issue History

Date Modified Username Field Change
2011-02-22 09:19 vrwp New Issue
2011-05-20 05:53 vrwp Note Added: 0001919
2011-05-20 22:28 vrwp Note Added: 0001920
2021-06-07 23:06 Steven Levine Assigned To => Steven Levine
2021-06-07 23:06 Steven Levine Status new => closed
2021-06-07 23:06 Steven Levine Resolution open => unable to reproduce
2021-06-07 23:06 Steven Levine Note Added: 0003718