View Issue Details

IDProjectCategoryView StatusLast Update
0000437PHP for OS/2, ArcaOS & eComStation (PHP versions v8.x v7.x v5.x)Bugpublic2022-05-14 16:35
Reporterjimoe Assigned Topsmedley  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Platformamd athlon x2 (32 bit)OSos/2OS Versionv4.50 fp3
Summary0000437: require_once() does not work
DescriptionPHP v5.2.14
httpd v2.2.16

I could find no indication at the PHP site that this was a generic problem.

After updating both httpd and PHP to the noted versions, one of the local websites ceased to function. The reason given was a duplicate function name, always the first function in the included file. (I tried moving the code around a bit to see what would happen.)

What had happened was that I had a require_once("some_filename") at the start of every PHP page file. When I noticed that, I added the same entry into the common include file that is included by every page. And then promptly forgot to erase said entry from each of the page files. Until upgrading to PHP v5.2.14.

Whatever magic is supposed to happen within require_once() is no longer happening.

The same applies to include_once(). I tried to load a rather complex application onto the os/2 server. It failed because an include_once() failed.

Steps To ReproduceIn the common included file:
<?php require_once("some_filename"); ...; ?>

Then in each page file:
<?php
    require_once("the_common_included_file");
    require_once("some_filename"); // <-- Error thrown here!
    ...;
?>

TagsNo tags attached.

Activities

psmedley

2022-05-14 16:35

administrator   ~0004276

Please retest with a supported build of PHP (ie 7.4 or above)

Issue History

Date Modified Username Field Change
2010-08-20 08:49 jimoe New Issue
2022-05-14 16:35 psmedley Assigned To => psmedley
2022-05-14 16:35 psmedley Status new => resolved
2022-05-14 16:35 psmedley Resolution open => won't fix
2022-05-14 16:35 psmedley Note Added: 0004276
2022-05-14 16:35 psmedley Status resolved => closed