View Issue Details

IDProjectCategoryView StatusLast Update
0000406Other Unix PortBugpublic2020-07-08 19:13
ReporterYodaAssigned Topsmedley 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Summary0000406: Want EggDrop updated to latest version, and fix for a few issues in older versions.
DescriptionI'd like to see a version of latest EggDrop :-)

All older EggDrop versions have a problem for TCL scripts.
When they use temp files, they never gets deleted.

[clock] commands in tcl scripts doesn't work. It seems to
require something extra compiled into the app.

Steps To ReproduceRun it !
TagsNo tags attached.

Activities

psmedley

2010-04-07 19:34

administrator   ~0001516

not looking good right now - stupid build fails with:
make[2]: ../../misc/modconfig: Command not found
make[2]: *** [static] Error 127
make[2]: Leaving directory `U:/dev/eggdrop1.6.19/src/mod'

of course modconfig does exist....

Yoda

2010-04-21 09:44

updater   ~0001542

Hmm, you have compiled 1.6.19 before into a working exe.

Yoda

2010-06-22 23:32

updater   ~0001604

Latest (egg)drop have the same old problems.

TMP files are not deleted (is scripts) so dir is getting filled
with files like:
10000001.tmp
10000002.tmp
10000003.tmp
10000004.tmp
10000005.tmp

Terminal mode doesn't work (eggdrop -t)

clock command missing in tcl

psmedley

2010-06-23 13:44

administrator   ~0001605

tmp files seems to be fixed with udpate to tcl 8.5.7

Yoda

2011-08-25 08:40

updater   ~0001961

I'd like a port of the latest 1.6.20

Please :-)

psmedley

2011-09-01 19:14

administrator   ~0001962

http://smedley.info/eggdrop1.6.20-os2-20101030.zip

Yoda

2011-09-03 07:13

updater   ~0001965

Temp files are fixed with 8.5.7 yes - also in .20

Haven't tested [clock] - all my scripts have workarounds
for it now .....

-nt (terminal mode) never worked for any of your builds;
would be nice to see this fixed too.

psmedley

2014-10-12 05:38

administrator   ~0002874

Hey Allan, do you still run Eggdrop on OS/2

Yoda

2014-11-28 05:41

updater   ~0002917

Sorry, I didn't notice this before now.
Yes, I still have Eggdrop running on OS/2

psmedley

2020-07-08 19:13

administrator   ~0003475

I have no plans to do further work on eggdrop

Issue History

Date Modified Username Field Change
2010-04-07 09:42 Yoda New Issue
2010-04-07 19:34 psmedley Note Added: 0001516
2010-04-21 09:44 Yoda Note Added: 0001542
2010-06-22 23:32 Yoda Note Added: 0001604
2010-06-23 13:44 psmedley Note Added: 0001605
2011-08-25 08:40 Yoda Note Added: 0001961
2011-09-01 19:14 psmedley Note Added: 0001962
2011-09-03 07:13 Yoda Note Added: 0001965
2011-12-31 19:01 psmedley Assigned To => psmedley
2011-12-31 19:01 psmedley Status new => assigned
2014-10-12 05:38 psmedley Note Added: 0002874
2014-11-28 05:41 Yoda Note Added: 0002917
2020-07-08 19:13 psmedley Status assigned => closed
2020-07-08 19:13 psmedley Resolution open => won't fix
2020-07-08 19:13 psmedley Note Added: 0003475