View Issue Details

IDProjectCategoryView StatusLast Update
0000352Apache 2.x Bugpublic2021-06-07 23:09
ReporterSteven LevineAssigned ToSteven Levine 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Versionv2.2.1 
Target VersionFixed in Version 
Summary0000352: file based authentication broken in 2.2.11
DescriptionFile based authentication with settings like

AuthType Basic
Require valid-user
AuthUserFile d:/internet/apache22/conf/.htpasswd

fails with errors of the form

[Tue May 12 16:10:49 2009] [crit] [client 192.168.10.2] configuration error: couldn't check access. No groups file?: /jsl/

The failure may be correct, but the error message is bogus. It appears to be caused by the code in server.c below line 182. The 2.3 trunk code drops the !ap_auth_type(r) checks which appear to be spurious.

The definition of ap_run_auth_checker seems to be well hidden. Can you locate it in the source tree? grep -i can not.

TagsNo tags attached.

Activities

psmedley

2011-12-31 19:06

administrator   ~0002110

is this still an issue?

Steven Levine

2021-06-07 23:09

manager   ~0003719

This issue does not seem to exist in current builds.

Issue History

Date Modified Username Field Change
2009-05-13 10:53 Steven Levine New Issue
2011-12-31 19:06 psmedley Note Added: 0002110
2021-06-07 23:09 Steven Levine Assigned To => Steven Levine
2021-06-07 23:09 Steven Levine Status new => closed
2021-06-07 23:09 Steven Levine Resolution open => unable to reproduce
2021-06-07 23:09 Steven Levine Note Added: 0003719