View Issue Details

IDProjectCategoryView StatusLast Update
0000003Sane for OS/2 & eComStationpublic2006-07-28 11:59
ReporterscanjetAssigned Topsmedley 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0000003: SANE doesn't work with my ScanJet 6300C
DescriptionI tried your new TAME/2 Version 103a and again my scanner doesn't work. It's a ScanJet 6300C.
The scanner is not reported when i run scanimage -L
Additional Informationi uploade a zipped debugoutput.txt
TagsNo tags attached.

Activities

psmedley

2006-04-03 08:40

administrator   ~0000004

Hi,
Can you please confirm the date/time of the last scanimage.exe & libsane.dll that worked for you?

That will help me trace back what has changed....

From an initial glance I can't see any changes in the USB code that would cause this problem....

scanjet

2006-04-04 07:02

reporter   ~0000007

Last known working files:
Scanimage.exe 40.964 15.12.2005 20:54
libsane.dll 1.618.306 01.01.2006 20:43

psmedley

2006-04-04 07:49

administrator   ~0000008

Hi Massi,
Can you please try http://smedley.info/libsanehp.zip - this has an older level of the USB code in it.

It it works I'll then try and identify what's changed.

scanjet

2006-05-10 04:57

reporter   ~0000072

Hi Paul,

don't know whom you meant with "Massi" but i now have tested the libsanehp.zip.
Unfortunately it still doesn't work....

psmedley

2006-05-15 07:03

administrator   ~0000073

Sorry - I got you mixed up with someone else.

Please try http://smedley.info/libsanehp.zip - this is again attempt to backlevel the USB code.

scanjet

2006-05-20 18:13

reporter   ~0000084

Hi Paul,
nice try but just another nogo..... Doesn't work...
I took the libsane.dll you provided for me and replaced the one in my working tame version and "scanimage -L" no longer reports my USB-Scanner.

PS: Hope i am not boring you......

psmedley

2006-05-20 19:54

administrator   ~0000085

Damn - no I'm not bored - I WANT to fix this :)

OK back to the drawing board...

psmedley

2006-05-24 16:34

administrator   ~0000095

http://smedley.info/tame103d.exe should fix this.
(Or http://smedley.info/libsane.zip if you just want a new libsane.dll)

scanjet

2006-05-24 19:07

reporter   ~0000096

I am sorry but i have to reopen the issue...
It is so crazy!!
Your new libsane.dll (05-25-2006) works with any older scanimage.exe.
I tested scanimage.exe (12-15-2005) and scanimage.exe (03-13-2006).

In the new package (103d, scanimage.exe 05-24-2006, libsane.dll 05-25-2006) one more time no USB-Scanner found.....

I'm sorry for that.... What now?

psmedley

2006-05-24 19:30

administrator   ~0000097

no need to apologise!

At least libsane.dll is working :)

This is totally strange.... are you sure Tame isn't picking up a libsane.dll from the libpath or something?

I guess it is possible that latest scanimage is broken - however it does work here

Can you do a debug log with the working scanimage.exe and also with the non-working one?

scanjet

2006-05-25 19:58

reporter   ~0000102

Provided the debug files you asked for.
debugoutput_bad.txt = actual Tame package 1.03d
debugoutput_good.zip = working version with scanimage.exe form 03-13-2006 and libsane.dll from 05-24-2006.

Greetings an many thanx
Thomas

scanjet

2006-06-14 03:58

reporter   ~0000120

Hi Paul,

did you see something within the latest logfiles i sent you?

psmedley

2006-06-14 08:14

administrator   ~0000121

Not much that's sensible....

Can you try with Tame 1.03f? Perhaps there was a quirk in the Sane CVS code that explains why the new scanimage didn't work but the libsane.dll did...

scanjet

2006-06-14 17:28

reporter   ~0000122

Gave it a try. Didn't work....
BUT:
Did some more testing again and maybe i isolated the problem (even think so).
Problem seems to be within the usbcalls.dll.
I installed your new TAME and then, after the software didn't work, replaced the actual usbcalls.dll with the one from my last working TAME and ... BINGO! It works.
The usbcalls.dll tame works with is from 2005-11-19, size 30.473
actual usbcalls.dll: 2006-06-12, 11.886
Hope this hint is helpful....

psmedley

2006-06-15 20:28

administrator   ~0000126

Can you please try http://smedley.info/tame103g.exe which contains latest usbresmg.sys & usbcalls from Froloff and rebuilt libsane.dll with a minor code change to the usb support.

scanjet

2006-06-16 18:46

reporter   ~0000130

1.0.3g works!!
Thank you!!

psmedley

2006-06-16 19:42

administrator   ~0000131

Hooray - finally fixed!

scanjet

2006-07-24 04:51

reporter   ~0000181

Paul,

one more time a new release (1.0.4) doesn't work for me..... :-(

I provided a debug.zip containing a working.debugoutput.txt from latest 1.0.3 and a broken.debugoutput.txt from 1.0.4

2006-07-24 04:52

 

DEBUG.ZIP (934,536 bytes)

psmedley

2006-07-24 09:58

administrator   ~0000182

Will look at the logs tonight - froloff probably changed a return code again :(

psmedley

2006-07-24 10:15

administrator   ~0000183

As I suspected, this is the error:
[sanei_usb] sanei_usb_read_bulk: rc = 7004
[sanei_usb] usbbulkread: error received.

Should be a 5 minute fix....

psmedley

2006-07-24 19:50

administrator   ~0000184

Please try http://smedley.info/libsanetest.zip

scanjet

2006-07-27 19:30

reporter   ~0000191

Problem fixed with the latest libsane.dll
Thank you.

Issue History

Date Modified Username Field Change
2006-04-02 21:58 scanjet New Issue
2006-04-02 21:58 scanjet File Added: debugoutput.txt.zip
2006-04-03 07:01 psmedley Status new => assigned
2006-04-03 07:01 psmedley Assigned To => psmedley
2006-04-03 08:40 psmedley Note Added: 0000004
2006-04-04 07:02 scanjet Note Added: 0000007
2006-04-04 07:49 psmedley Note Added: 0000008
2006-05-10 04:57 scanjet Note Added: 0000072
2006-05-15 07:03 psmedley Note Added: 0000073
2006-05-20 18:13 scanjet Note Added: 0000084
2006-05-20 19:54 psmedley Note Added: 0000085
2006-05-24 16:34 psmedley Status assigned => resolved
2006-05-24 16:34 psmedley Resolution open => fixed
2006-05-24 16:34 psmedley Note Added: 0000095
2006-05-24 19:07 scanjet Status resolved => feedback
2006-05-24 19:07 scanjet Resolution fixed => reopened
2006-05-24 19:07 scanjet Note Added: 0000096
2006-05-24 19:30 psmedley Note Added: 0000097
2006-05-25 19:52 scanjet File Added: debugoutput_bad.txt
2006-05-25 19:54 scanjet File Added: debugoutput_good.zip
2006-05-25 19:58 scanjet Note Added: 0000102
2006-06-14 03:58 scanjet Note Added: 0000120
2006-06-14 08:14 psmedley Note Added: 0000121
2006-06-14 17:28 scanjet Note Added: 0000122
2006-06-15 20:28 psmedley Note Added: 0000126
2006-06-16 18:46 scanjet Note Added: 0000130
2006-06-16 19:42 psmedley Status feedback => closed
2006-06-16 19:42 psmedley Note Added: 0000131
2006-06-16 19:42 psmedley Resolution reopened => fixed
2006-07-24 04:51 scanjet Status closed => feedback
2006-07-24 04:51 scanjet Resolution fixed => reopened
2006-07-24 04:51 scanjet Note Added: 0000181
2006-07-24 04:52 scanjet File Added: DEBUG.ZIP
2006-07-24 09:58 psmedley Note Added: 0000182
2006-07-24 10:15 psmedley Note Added: 0000183
2006-07-24 19:50 psmedley Note Added: 0000184
2006-07-24 19:56 psmedley File Deleted: debugoutput.txt.zip
2006-07-24 19:57 psmedley File Deleted: debugoutput_bad.txt
2006-07-24 19:57 psmedley File Deleted: debugoutput_good.zip
2006-07-27 19:30 scanjet Note Added: 0000191
2006-07-28 11:59 psmedley Status feedback => closed
2006-07-28 11:59 psmedley Resolution reopened => fixed