View Issue Details

IDProjectCategoryView StatusLast Update
0000267Subversion for OS/2 & eCSBugpublic2020-09-27 07:08
ReporterguerfyldAssigned Topsmedley 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000267: Code page problème in 'svn log'
DescriptionUnder windows (cp850) :
add new file containing "àéiôù"
commit chnage with message "Test éàô"
update working copy : all is OK

Under OS2 (cp850) - with same repositary :
checkout working copy
File containt "àéiôù" -> OK
but 'svn log' display :
------------------------------------------------------------------------
r1 | guerfyld | 2008-08-20 10:57:39 +0100 (mer., 20 ao¹t 2008) | 1 line

Test ÚÓ¶

If I change code page (chcp 1004), 'svn log' display correct log message.
Additional InformationTested on v1.4.4 and 1.5.1
TagsNo tags attached.

Activities

psmedley

2008-08-21 11:46

administrator   ~0000944

can you send me the sample file so that I can try and reproduce?

psmedley

2008-08-21 11:46

administrator   ~0000945

can you send me the sample file so that I can try and reproduce?

2008-08-21 21:58

 

repos.zip (17,785 bytes)

guerfyld

2008-08-21 21:58

reporter   ~0000946

I have upload a zip of repositary.

The command "svn co file:///repos prj" create this directory structure :
prj/
prj/file.txt

file.txt content is "àéiôù" under Win and OS/2 (codepage 850)

svn log display correct message under OS2 only if I execute "chcp 1004".

psmedley

2020-08-31 09:43

administrator   ~0003524

Please test with 1.14.0

Issue History

Date Modified Username Field Change
2008-08-20 20:55 guerfyld New Issue
2008-08-21 11:46 psmedley Note Added: 0000944
2008-08-21 11:46 psmedley Note Added: 0000945
2008-08-21 21:58 guerfyld File Added: repos.zip
2008-08-21 21:58 guerfyld Note Added: 0000946
2020-08-31 09:43 psmedley Assigned To => psmedley
2020-08-31 09:43 psmedley Status new => feedback
2020-08-31 09:43 psmedley Note Added: 0003524
2020-09-27 07:08 psmedley Status feedback => closed
2020-09-27 07:08 psmedley Resolution open => unable to reproduce